summaryrefslogtreecommitdiffstats
path: root/avl-1.4.0
diff options
context:
space:
mode:
authorEric Norum <WENorum@lbl.gov>1999-08-07 22:44:04 +0000
committerEric Norum <WENorum@lbl.gov>1999-08-07 22:44:04 +0000
commit9f2e68279cdb85660b1505a5dedca582382c0fd4 (patch)
treedbc2fa23c9c858873e2e79e72433ec887a33b3a4 /avl-1.4.0
parentUseful add-on libraries (diff)
downloadrtems-addon-packages-9f2e68279cdb85660b1505a5dedca582382c0fd4.tar.bz2
Useful add-on libraries
Diffstat (limited to 'avl-1.4.0')
-rw-r--r--avl-1.4.0/Makefile.am28
-rw-r--r--avl-1.4.0/README37
-rw-r--r--avl-1.4.0/configure.in5
3 files changed, 70 insertions, 0 deletions
diff --git a/avl-1.4.0/Makefile.am b/avl-1.4.0/Makefile.am
new file mode 100644
index 0000000..aa4754d
--- /dev/null
+++ b/avl-1.4.0/Makefile.am
@@ -0,0 +1,28 @@
+AUTOMAKE_OPTIONS = gnits
+
+include_HEADERS = avl.h avlt.h avltr.h rb.h
+
+lib_LIBRARIES = libavl.a
+libavl_a_SOURCES = avl.c avlt.c avltr.c rb.c
+
+info_TEXINFOS = avl.texinfo
+noinst_DATA = avl.html avl.text
+
+avl.text : avl.texinfo
+ $(MAKEINFO) $(srcdir)/avl.texinfo -o avl.text --no-headers
+
+avl.html: avl.texinfo
+ -texi2html -monolithic $(srcdir)/avl.texinfo
+
+EXTRA_PROGRAMS = avl-test avlt-test avltr-test thread-test rb-test
+DISTCLEANFILES = $(EXTRA_PROGRAMS) $(BUILT_SOURCES)
+
+BUILT_SOURCES = avl-test.c avlt-test.c avltr-test.c rb-test.c
+
+TESTS = avl-test avlt-test avltr-test thread-test rb-test
+avl-test.c avlt-test.c avltr-test.c rb-test.c:
+ rm -f $@
+ echo '#define SELF_TEST 1' > $@
+ echo '#include "'`echo $@ | sed s/-test//`'"' >> $@
+
+thread_test_LDADD = libavl.a
diff --git a/avl-1.4.0/README b/avl-1.4.0/README
new file mode 100644
index 0000000..46ed6e4
--- /dev/null
+++ b/avl-1.4.0/README
@@ -0,0 +1,37 @@
+This is version 1.4 of libavl, a library in ANSI C for manipulation of
+balanced binary trees. Functions for use with three varieties of AVL
+tree and one type of red-black tree are included. There is full
+documentation, including an explanation of what AVL and red-black
+trees are and why you'd use them, in Texinfo, Info, HTML, and plain
+text formats.
+
+The library is divided into three parts, described in more detail
+below. You need only include the files for the types of trees that
+you are using.
+
+ - avl.h, avl.c: Unthreaded AVL tree library.
+ - avlt.h, avlt.c: Threaded AVL tree library.
+ - avltr.h, avltr.c: Right-threaded AVL tree library.
+ - rb.h, rb.c: Unthreaded red-black tree library.
+
+Each .c file in the library has a self-test routine built in, which
+can be invoked by compiling it with SELF_TEST set to 1. In addition,
+there is a separate program thread-test.c that tests the functions
+that convert among types of AVL trees. To automatically run these
+tests, type `make check' after you have configured the library with
+`configure'. For more information on how to configure and compile
+libavl, see the file INSTALL included in this directory.
+
+libavl is licensed under the GNU General Public License (GPL), which
+should be included in this directory in file COPYING. This is not the
+same as GNU Library General Public License (LGPL). Please read the
+license and become familiar with its terms.
+
+Please send bug reports and enhancement requests for libavl to Ben
+Pfaff <blp@gnu.org>.
+
+Share and enjoy!
+
+Local variables:
+mode: text
+End:
diff --git a/avl-1.4.0/configure.in b/avl-1.4.0/configure.in
new file mode 100644
index 0000000..118f3c8
--- /dev/null
+++ b/avl-1.4.0/configure.in
@@ -0,0 +1,5 @@
+AC_INIT(avl.c)
+AM_INIT_AUTOMAKE(avl, 1.4.0)
+AC_PROG_CC
+AC_PROG_RANLIB
+AC_OUTPUT(Makefile)