summaryrefslogtreecommitdiffstats
path: root/RTEMS_Makefiles/Makefile.common
diff options
context:
space:
mode:
authorEric Norum <WENorum@lbl.gov>2002-06-28 21:52:18 +0000
committerEric Norum <WENorum@lbl.gov>2002-06-28 21:52:18 +0000
commite8dcb4b635612f7c91fa6b318995e36018674bd6 (patch)
tree0ec7636f4f962b9008558ab0e998afb293127195 /RTEMS_Makefiles/Makefile.common
parentUseful add-on libraries (diff)
downloadrtems-addon-packages-e8dcb4b635612f7c91fa6b318995e36018674bd6.tar.bz2
Useful add-on libraries
Diffstat (limited to 'RTEMS_Makefiles/Makefile.common')
-rw-r--r--RTEMS_Makefiles/Makefile.common23
1 files changed, 23 insertions, 0 deletions
diff --git a/RTEMS_Makefiles/Makefile.common b/RTEMS_Makefiles/Makefile.common
new file mode 100644
index 0000000..7e0ddbe
--- /dev/null
+++ b/RTEMS_Makefiles/Makefile.common
@@ -0,0 +1,23 @@
+###########################################################
+# Meta-Makefile for compiling packages to work with RTEMS #
+###########################################################
+
+#
+# Pick up RTEMS configuration
+#
+include $(RTEMS_MAKEFILE_PATH)/Makefile.inc
+include $(RTEMS_CUSTOM)
+include $(PROJECT_ROOT)/make/leaf.cfg
+CC += $(CPU_CFLAGS)
+
+#
+# For some reason RTEMS Makefiles don't export this
+#
+export RANLIB
+
+.PHONY: all
+
+#
+# Include site-specific options
+#
+include ../RTEMS_Makefiles/Makefile.site