summaryrefslogtreecommitdiffstats
path: root/wscript
diff options
context:
space:
mode:
authorVijay Kumar Banerjee <vijaykumar9597@gmail.com>2019-08-29 02:46:03 +0530
committerVijay Kumar Banerjee <vijaykumar9597@gmail.com>2019-08-29 02:46:03 +0530
commit399b4fa48f57f760376854c4c1b36cd07accb92a (patch)
tree4f87e364057eec7d19ddb26c3bad10f1a367fc4f /wscript
parentAdd conf headers (diff)
downloadrtems-littlevgl-399b4fa48f57f760376854c4c1b36cd07accb92a.tar.bz2
Add lvgl.py
+Added support to parse source and cflags from .mk file
Diffstat (limited to 'wscript')
-rw-r--r--wscript39
1 files changed, 5 insertions, 34 deletions
diff --git a/wscript b/wscript
index 0f9ce45..23ae421 100644
--- a/wscript
+++ b/wscript
@@ -1,7 +1,8 @@
#
# RTEMS Project (https://www.rtems.org/)
#
-# Copyright (c) 2019 Vijay Kumar Banerjee. All rights reserved.
+# Copyright (c) 2019 Vijay Kumar Banerjee <vijaykumar9597@gmail.com>.
+# All rights reserved.
#
# Redistribution and use in source and binary forms, with or without
# modification, are permitted provided that the following conditions
@@ -42,47 +43,17 @@ except:
import os.path
import runpy
import sys
-try:
- import configparser
-except ImportError:
- import ConfigParser as configparser
-import waflib.Options
-
-builders = {}
-
-def bsp_init(ctx, env, contexts):
- # This function generates the builders and adds build-xxx, clean-xxx and
- # install-xxx targets for them.
- # Transform the commands to per build variant commands
- commands = []
- for cmd in waflib.Options.commands:
- if cmd.startswith(('build', 'clean', 'install')):
- for builder in builders:
- commands += [cmd + '-' + builder]
- else:
- commands += [cmd]
- waflib.Options.commands = commands
+import waflib.Options
def init(ctx):
- rtems.init(ctx, version = rtems_version, long_commands = True,
- bsp_init = bsp_init)
+ rtems.init(ctx, version = rtems_version, long_commands = True)
def options(opt):
rtems.options(opt)
- opt.add_option("--enable-warnings",
- action = "store_true",
- default = False,
- dest = "warnings",
- help = "Enable all warnings. The default is quiet builds.")
-
-def bsp_configure(conf, arch_bsp):
- env = conf.env.derive()
def configure(conf):
- conf.env.WARNINGS = conf.options.warnings
-
- rtems.configure(conf, bsp_configure)
+ rtems.configure(conf)
def build(bld):
rtems.build(bld)