summaryrefslogtreecommitdiffstats
path: root/bsd_eth_drivers/if_fxp/Makefile.am
diff options
context:
space:
mode:
authorTill Straumann <strauman@slac.stanford.edu>2009-04-23 04:54:18 +0000
committerTill Straumann <strauman@slac.stanford.edu>2009-04-23 04:54:18 +0000
commita706aadf4a136e796bbfa4d0b9029f571a251168 (patch)
tree1ef488192e7cd2d284440740cd18534f7e833e9c /bsd_eth_drivers/if_fxp/Makefile.am
parentThis commit was generated by cvs2svn to compensate for changes in r44, which (diff)
downloadlibbsdport-a706aadf4a136e796bbfa4d0b9029f571a251168.tar.bz2
- ported to RTEMS.
Diffstat (limited to 'bsd_eth_drivers/if_fxp/Makefile.am')
-rw-r--r--bsd_eth_drivers/if_fxp/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/bsd_eth_drivers/if_fxp/Makefile.am b/bsd_eth_drivers/if_fxp/Makefile.am
new file mode 100644
index 0000000..f58c259
--- /dev/null
+++ b/bsd_eth_drivers/if_fxp/Makefile.am
@@ -0,0 +1,22 @@
+# $Id$
+AUTOMAKE_OPTIONS=foreign
+
+include $(top_srcdir)/rtems-pre.am
+
+libif_fxp_a_SOURCES = if_fxp.c
+libif_fxp_a_SOURCES += if_fxpreg.h if_fxpvar.h rcvbundl.h
+
+lib_LIBRARIES = libif_fxp.a
+
+AM_CPPFLAGS += -I$(srcdir)
+AM_CPPFLAGS += -I$(srcdir)/../libbsdport -I../libbsdport -I../libbsdport/dummyheaders
+AM_CPPFLAGS += $(CPPFLAGS_82542_SUPPORT_$(ENBL_82542_SUPPORT))
+AM_CPPFLAGS += $(CPPFLAGS_ICH8LAN_SUPPORT_$(ENBL_ICH8LAN_SUPPORT))
+
+LINKS = dev/fxp/if_fxpreg.h dev/fxp/if_fxpvar.h dev/fxp/rcvbundl.h
+
+BUILT_SOURCES =
+
+$(libif_fxp_a_OBJECTS): $(LINKS)
+
+include ../links.am