summaryrefslogtreecommitdiffstats
path: root/bsd_eth_drivers/if_em/Makefile.am
diff options
context:
space:
mode:
authorTill Straumann <strauman@slac.stanford.edu>2011-07-20 17:25:21 +0000
committerTill Straumann <strauman@slac.stanford.edu>2011-07-20 17:25:21 +0000
commit88f653ad2e278a42c3c1c480022820abdeea233f (patch)
tree56329574a0093a9db1385b31124d9e92136afec3 /bsd_eth_drivers/if_em/Makefile.am
parent2010-07-23 Till Straumann <Till.Straumann@TU-Berlin.de> (diff)
downloadlibbsdport-88f653ad2e278a42c3c1c480022820abdeea233f.tar.bz2
2011-07-20 Till Straumann <Till.Straumann@TU-Berlin.de>
* if_em/Makefile.am, if_em/e1000_osdep.h, if_em/e1000_osdep.c, if_em/if_em.c: added e1000_osdep.c which implements all os-dependent parts in a bsdnet-agnostic fashion. Hence, the low-level driver can be used w/o bsdnet. FIXES: dependency on bsdnet initialization; PCI bus header was not initialized when not used via bsdnet (lanIpBasic driver crashed).
Diffstat (limited to 'bsd_eth_drivers/if_em/Makefile.am')
-rw-r--r--bsd_eth_drivers/if_em/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/bsd_eth_drivers/if_em/Makefile.am b/bsd_eth_drivers/if_em/Makefile.am
index a795ef8..f1e26b0 100644
--- a/bsd_eth_drivers/if_em/Makefile.am
+++ b/bsd_eth_drivers/if_em/Makefile.am
@@ -4,6 +4,7 @@ AUTOMAKE_OPTIONS=foreign
include $(top_srcdir)/rtems-pre.am
libif_em_a_SOURCES = if_em.c
+libif_em_a_SOURCES += e1000_osdep.c
libif_em_a_SOURCES += e1000_80003es2lan.c e1000_82540.c e1000_82541.c
libif_em_a_SOURCES += e1000_82543.c e1000_82571.c e1000_82575.c
libif_em_a_SOURCES += e1000_api.c e1000_mac.c e1000_manage.c
@@ -15,6 +16,8 @@ libif_em_a_SOURCES += e1000_defines.h e1000_hw.h e1000_ich8lan.h
libif_em_a_SOURCES += e1000_mac.h e1000_manage.h e1000_nvm.h
libif_em_a_SOURCES += e1000_osdep.h e1000_phy.h e1000_regs.h if_em.h
+if_em.$(OBJEXT): AM_SRC_CPPFLAGS=-D_KERNEL
+
EXTRA_libif_em_a_SOURCES = e1000_82542.c e1000_ich8lan.c
CPPFLAGS_82542_SUPPORT_NO = -DNO_82542_SUPPORT
@@ -31,10 +34,10 @@ libif_em_a_DEPENDENCIES = $(libif_em_a_LIBADD)
lib_LIBRARIES = libif_em.a
-AM_CPPFLAGS += -D_KERNEL
AM_CPPFLAGS += -I$(srcdir)
AM_CPPFLAGS += -I$(srcdir)/../libbsdport -I../libbsdport -I../libbsdport/dummyheaders
AM_CPPFLAGS += $(CPPFLAGS_82542_SUPPORT_$(ENBL_82542_SUPPORT))
AM_CPPFLAGS += $(CPPFLAGS_ICH8LAN_SUPPORT_$(ENBL_ICH8LAN_SUPPORT))
+AM_CPPFLAGS += $(AM_SRC_CPPFLAGS)
include $(top_srcdir)/rtems.am