summaryrefslogtreecommitdiffstats
path: root/bsd_eth_drivers/if_bge/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2009-02-20 21:24:30 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2009-02-20 21:24:30 +0000
commit1039919dc0c9ac8561c305f604348449c1c8fb40 (patch)
tree381ae4d4c4dc0ddaecc68f292f354b0085afae04 /bsd_eth_drivers/if_bge/Makefile.am
parent - use separate #ifdef __rtems__ branch when using bus_setup_intr() because (diff)
downloadlibbsdport-1039919dc0c9ac8561c305f604348449c1c8fb40.tar.bz2
2009-02-20 Joel Sherrill <joel.sherrill@oarcorp.com>
* configure.ac, bsd_eth_drivers/Makefile.am, bsd_eth_drivers/libbsdport/alldrv.c, bsd_eth_drivers/libbsdport/libbsdport_api.h: Add first cut at Broadcomm BCM57xx driver. * bsd_eth_drivers/if_bge/.cvsignore, bsd_eth_drivers/if_bge/Makefile.am, bsd_eth_drivers/if_bge/if_bge.c, bsd_eth_drivers/if_bge/if_bgereg.h: New files.
Diffstat (limited to 'bsd_eth_drivers/if_bge/Makefile.am')
-rw-r--r--bsd_eth_drivers/if_bge/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/bsd_eth_drivers/if_bge/Makefile.am b/bsd_eth_drivers/if_bge/Makefile.am
new file mode 100644
index 0000000..1290360
--- /dev/null
+++ b/bsd_eth_drivers/if_bge/Makefile.am
@@ -0,0 +1,22 @@
+# $Id$
+AUTOMAKE_OPTIONS=foreign
+
+include $(top_srcdir)/rtems-pre.am
+
+libif_bge_a_SOURCES = if_bge.c if_bgereg.h
+
+##EXTRA_libif_bge_a_SOURCES =
+
+CPPFLAGS_82542_SUPPORT_NO = -DNO_82542_SUPPORT
+CPPFLAGS_ICH8LAN_SUPPORT_NO = -DNO_ICH8LAN_SUPPORT
+
+libif_bge_a_LIBADD =
+
+libif_bge_a_DEPENDENCIES = $(libif_bge_a_LIBADD)
+
+lib_LIBRARIES = libif_bge.a
+
+AM_CPPFLAGS += -I$(srcdir)
+AM_CPPFLAGS += -I$(srcdir)/../libbsdport -I../libbsdport -I../libbsdport/dummyheaders
+
+include $(top_srcdir)/rtems.am