summaryrefslogtreecommitdiff
path: root/testsuites/libtests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/libtests/Makefile.am')
-rw-r--r--testsuites/libtests/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/testsuites/libtests/Makefile.am b/testsuites/libtests/Makefile.am
index 1b80283123..406961ca73 100644
--- a/testsuites/libtests/Makefile.am
+++ b/testsuites/libtests/Makefile.am
@@ -1160,6 +1160,14 @@ lib_docs += record02/record02.doc
record02_SOURCES = record02/init.c
record02_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_record02) \
$(support_includes)
+record02_LDADD = $(LDADD) $(RTEMS_ROOT)cpukit/librtemsrecordwrap.a $(LDADD)
+record02_LDFLAGS = $(AM_LDFLAGS)
+record02_LDFLAGS += -Wl,--wrap=aligned_alloc
+record02_LDFLAGS += -Wl,--wrap=calloc
+record02_LDFLAGS += -Wl,--wrap=malloc
+record02_LDFLAGS += -Wl,--wrap=free
+record02_LDFLAGS += -Wl,--wrap=posix_memalign
+record02_LDFLAGS += -Wl,--wrap=realloc
endif
if TEST_rtmonuse