summaryrefslogtreecommitdiff
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorChris Johns <chrisj@rtems.org>2018-12-17 16:36:48 +1100
committerChris Johns <chrisj@rtems.org>2019-02-09 10:06:34 +1100
commit89c59be38d9c83437abb9002e8fea5012652e5ff (patch)
tree954df408c26a58ae41851502f427f30771952bdf /cpukit/Makefile.am
parentb08278e8520d14e5b809bb07785b724c7a127e29 (diff)
libdl: Add symbol searching and loading from archives.
- Load archive symbol tables to support searching of archives for symbols. - Search archive symbols and load the object file that contains the symbol. - Search the global and archives until all remaining unresolved symbols are not found. Group the loaded object files in the pending queue. - Run the object file and loaded dependents as a group before adding to the main object list. - Remove orphaned object files after references are removed. Updates #3686
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index 7a138c0c6e..8ea7cbbfb0 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -1140,6 +1140,7 @@ librtemscpu_a_SOURCES += libdl/rap.c
librtemscpu_a_SOURCES += libdl/rap-shell.c
librtemscpu_a_SOURCES += libdl/rtl-allocator.c
librtemscpu_a_SOURCES += libdl/rtl-alloc-heap.c
+librtemscpu_a_SOURCES += libdl/rtl-archive.c
librtemscpu_a_SOURCES += libdl/rtl.c
librtemscpu_a_SOURCES += libdl/rtl-chain-iterator.c
librtemscpu_a_SOURCES += libdl/rtl-debugger.c