summaryrefslogtreecommitdiff
path: root/gsl-1.9/roots/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gsl-1.9/roots/Makefile.am')
-rw-r--r--gsl-1.9/roots/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/gsl-1.9/roots/Makefile.am b/gsl-1.9/roots/Makefile.am
new file mode 100644
index 0000000..2ea5015
--- /dev/null
+++ b/gsl-1.9/roots/Makefile.am
@@ -0,0 +1,19 @@
+# -*-makefile-*-
+
+noinst_LTLIBRARIES = libgslroots.la
+
+pkginclude_HEADERS = gsl_roots.h
+
+noinst_HEADERS = roots.h
+
+INCLUDES= -I$(top_builddir)
+
+libgslroots_la_SOURCES = bisection.c brent.c falsepos.c newton.c secant.c steffenson.c convergence.c fsolver.c fdfsolver.c
+
+check_PROGRAMS = test
+
+TESTS = $(check_PROGRAMS)
+
+test_SOURCES = test.c test_funcs.c test.h
+test_LDADD = libgslroots.la ../ieee-utils/libgslieeeutils.la ../err/libgslerr.la ../test/libgsltest.la ../sys/libgslsys.la ../utils/libutils.la
+