summaryrefslogtreecommitdiff
path: root/gsl-1.9/qrng/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gsl-1.9/qrng/Makefile.am')
-rw-r--r--gsl-1.9/qrng/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/gsl-1.9/qrng/Makefile.am b/gsl-1.9/qrng/Makefile.am
new file mode 100644
index 0000000..b33787a
--- /dev/null
+++ b/gsl-1.9/qrng/Makefile.am
@@ -0,0 +1,14 @@
+noinst_LTLIBRARIES = libgslqrng.la
+
+pkginclude_HEADERS = gsl_qrng.h
+
+INCLUDES= -I$(top_builddir)
+
+libgslqrng_la_SOURCES = gsl_qrng.h qrng.c niederreiter-2.c sobol.c
+
+TESTS = $(check_PROGRAMS)
+check_PROGRAMS = test
+
+test_SOURCES = test.c
+test_LDADD = libgslqrng.la ../ieee-utils/libgslieeeutils.la ../err/libgslerr.la ../test/libgsltest.la ../sys/libgslsys.la ../utils/libutils.la
+