summaryrefslogtreecommitdiff
path: root/gsl-1.9/ieee-utils/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gsl-1.9/ieee-utils/Makefile.am')
-rw-r--r--gsl-1.9/ieee-utils/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/gsl-1.9/ieee-utils/Makefile.am b/gsl-1.9/ieee-utils/Makefile.am
new file mode 100644
index 0000000..559e531
--- /dev/null
+++ b/gsl-1.9/ieee-utils/Makefile.am
@@ -0,0 +1,14 @@
+noinst_LTLIBRARIES = libgslieeeutils.la
+
+pkginclude_HEADERS = gsl_ieee_utils.h
+
+libgslieeeutils_la_SOURCES = print.c make_rep.c gsl_ieee_utils.h env.c fp.c read.c
+
+noinst_HEADERS = fp-aix.c fp-darwin.c fp-darwin86.c fp-hpux.c fp-hpux11.c fp-irix.c fp-gnum68k.c fp-gnuppc.c fp-solaris.c fp-gnusparc.c fp-sunos4.c fp-tru64.c fp-unknown.c fp-gnux86.c fp-freebsd.c fp-os2emx.c fp-netbsd.c fp-openbsd.c fp-gnuc99.c endian.c standardize.c
+
+INCLUDES= -I$(top_builddir)
+
+TESTS = $(check_PROGRAMS)
+check_PROGRAMS = test
+test_LDADD = libgslieeeutils.la ../err/libgslerr.la ../test/libgsltest.la ../sys/libgslsys.la ../utils/libutils.la
+test_SOURCES = test.c