summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJiri Gaisler <jiri@gaisler.se>2019-05-28 00:02:40 +0200
committerJiri Gaisler <jiri@gaisler.se>2019-05-28 00:09:27 +0200
commit9277f1913aa341efbf6d111ec25e1dc863158cf5 (patch)
tree71fd2e77837ad5cd15d732ec208bfeca990ed275 /configure.ac
parent6a742ad589f8a5967cb878e4065f70d93b90fb58 (diff)
Made L1 cache optional through --enable-l1cache
* Removed stale config.h * Updated autoconf script with relevant checks * Re-implemented leon3/grlib timer with less events * Bumped version to 2.15
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index f2627cc..c7c5083 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,15 +1,21 @@
-AC_INIT([sis], [2.14])
+AC_INIT([sis], [2.15])
AC_CONFIG_SRCDIR([sis.c])
AC_CONFIG_AUX_DIR([build-aux])
AC_CONFIG_HEADERS(config.h)
AM_INIT_AUTOMAKE([-Wall -Werror foreign])
AC_PROG_CC
-AC_CHECK_HEADERS([fcntl.h stddef.h stdlib.h string.h sys/time.h unistd.h])
+AC_CHECK_HEADERS([fcntl.h stddef.h stdlib.h string.h sys/time.h unistd.h termios.h])
AC_CONFIG_FILES([Makefile])
AC_CHECK_LIB(readline, readline, READLINE=-lreadline,
AC_ERROR([the required "readline" library is missing]), $READLINE)
AC_SUBST(READLINE)
+AC_ARG_ENABLE([l1cache], [ --enable-l1cache enable L1 cache emulation])
+AS_IF([test "x$enable_l1cache" = "xyes"],
+ [AC_DEFINE([ENABLE_L1CACHE], [1], ["enable L1 cache emulation"])])
+
+AC_C_BIGENDIAN
+
AC_OUTPUT