summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChris Johns <chrisj@rtems.org>2019-07-02 09:57:28 +1000
committerJiri Gaisler <jiri@gaisler.se>2019-07-02 22:03:52 +0200
commitd509fe6c57f18e2534c586e7dde844811c76a146 (patch)
tree6e667f33725e141a9af9ae166f9ecbfa1c90deb2 /Makefile.am
parent787997a6e90e22537d61f4c155ac0a5bf2018109 (diff)
Make readline conditional and add linenoise it not present.
- Readline is not present on all hosts is used on and it has not been a requirement. Rather than break all hosts that are working this patch conditionally adds linenoise a small simple realline replacement.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 10 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 4307816..ef24f57 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,11 +1,18 @@
+if LINENOISE
+ LN_SRC=linenoise.c
+else
+ LN_SRC=
+endif
+
bin_PROGRAMS = sis
sis_SOURCES = erc32.c float.c grlib.c leon3.c exec.c func.c help.c \
- sparc.c riscv.c leon2.c sis.c interf.c remote.c elf.c
+ sparc.c riscv.c leon2.c sis.c interf.c remote.c elf.c \
+ $(LN_SRC)
AM_CFLAGS = -DFAST_UART
-sis_LDADD = -lm -lreadline
+sis_LDADD = -lm @READLINE@
info_TEXINFOS = sis.texi
.PHONY: v
-v: version.texi
+v: version.texi