summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJiri Gaisler <jiri@gaisler.se>2020-12-05 17:49:25 +0100
committerJiri Gaisler <jiri@gaisler.se>2020-12-15 15:28:09 +0100
commit36b4b0a9b95a351fc99ca3224503dab9e29af865 (patch)
tree2364018e2cc1e3118672e841b84bc545caf316a8 /Makefile.am
parentbb65f4484f9be1818435ca39e95feab35be427aa (diff)
Added support for RISCV32 systems with CLINT/PLIC
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 384a58f..6a94413 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,12 +7,16 @@ endif
bin_PROGRAMS = sis
sis_SOURCES = erc32.c grlib.c leon3.c exec.c func.c help.c \
sparc.c riscv.c leon2.c sis.c interf.c remote.c elf.c \
- greth.c tap.c gr740.c \
+ greth.c tap.c gr740.c rv32.c \
$(LN_SRC)
AM_CFLAGS = -DFAST_UART
sis_LDADD = -lm @READLINE@ @LIBADD@
-EXTRA_DIST = elf.h grlib.h linenoise.h riscv.h sis.h sparc.h
+EXTRA_DIST = elf.h grlib.h linenoise.h riscv.h sis.h sparc.h rv32dtb.h
+
+rv32dtb.h: $(abs_srcdir)/rv32.dts
+ dtc -O dtb $(abs_srcdir)/rv32.dts -o rv32.dtb
+ xxd --include rv32.dtb > rv32dtb.h
info_TEXINFOS = sis.texi