summaryrefslogtreecommitdiff
path: root/testsuites/libtests/mathf/Makefile.am
diff options
context:
space:
mode:
authorcvs2git <rtems-devel@rtems.org>2011-03-18 10:11:42 +0000
committercvs2git <rtems-devel@rtems.org>2011-03-18 10:11:42 +0000
commite371ea9949ecc8897f4cb34437cc6590a0fc51f0 (patch)
treee5d17499fe12fc87c9697d681b63b062e9cbb65a /testsuites/libtests/mathf/Makefile.am
parent83dcd23af45446b24fe12e5bce29432debe6d0b5 (diff)
This commit was manufactured by cvs2svn to create tag 'rtems-4-10-0'.4.10.0
Sprout from rtems-4-10-branch 2011-02-08 15:56:24 UTC Joel Sherrill <joel.sherrill@OARcorp.com> 'Ensure all version instances say 4.10.' Cherrypick from rtems-4-10-branch 2011-03-18 10:11:41 UTC cvs2git <rtems-devel@rtems.org> 'This commit was manufactured by cvs2svn to create branch': cpukit/zlib/ChangeLog cpukit/zlib/ChangeLog.zlib cpukit/zlib/FAQ cpukit/zlib/Makefile.am cpukit/zlib/README cpukit/zlib/adler32.c cpukit/zlib/compress.c cpukit/zlib/crc32.c cpukit/zlib/deflate.c cpukit/zlib/deflate.h cpukit/zlib/doc/algorithm.txt cpukit/zlib/gzclose.c cpukit/zlib/gzguts.h cpukit/zlib/gzlib.c cpukit/zlib/gzread.c cpukit/zlib/gzwrite.c cpukit/zlib/infback.c cpukit/zlib/inffast.c cpukit/zlib/inflate.c cpukit/zlib/inflate.h cpukit/zlib/inftrees.c cpukit/zlib/inftrees.h cpukit/zlib/trees.c cpukit/zlib/uncompr.c cpukit/zlib/zconf.h cpukit/zlib/zlib.3 cpukit/zlib/zlib.h cpukit/zlib/zutil.c cpukit/zlib/zutil.h testsuites/libtests/mathf/.cvsignore testsuites/libtests/mathf/Makefile.am testsuites/libtests/mathf/domathf.c testsuites/libtests/mathf/init.c testsuites/libtests/mathf/mathf.scn
Diffstat (limited to 'testsuites/libtests/mathf/Makefile.am')
-rw-r--r--testsuites/libtests/mathf/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/testsuites/libtests/mathf/Makefile.am b/testsuites/libtests/mathf/Makefile.am
new file mode 100644
index 0000000000..57b372e08f
--- /dev/null
+++ b/testsuites/libtests/mathf/Makefile.am
@@ -0,0 +1,30 @@
+##
+## $Id$
+##
+
+rtems_tests_PROGRAMS = mathf
+mathf_SOURCES = init.c domathf.c
+EXTRA_DIST = $(srcdir)/../math/domath.in
+
+$(srcdir)/domathf.c: $(srcdir)/../math/domath.in
+ sed -e 's,[@]FTYPE[@],float,' \
+ -e 's,[@]FSUFFIX[@],f,g' \
+ -e 's,[@]FGUARD[@],NO_FLOAT,' \
+ $(srcdir)/../math/domath.in > $(srcdir)/domathf.c
+
+dist_rtems_tests_DATA = mathf.scn
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+mathf_LDADD = -lm
+
+LINK_OBJS = $(mathf_OBJECTS) $(mathf_LDADD)
+LINK_LIBS = $(mathf_LDLIBS)
+
+mathf$(EXEEXT): $(mathf_OBJECTS) $(mathf_DEPENDENCIES)
+ @rm -f mathf$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am