summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2018-06-15 08:18:26 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2018-06-15 12:57:32 +0200
commitbac8d934189c02635cca752d36dce1fdad6338b8 (patch)
treee4ce8981b76b63db037a8ba8409852aa98b9b83b /configure.ac
parent1f283f17a8daee9e9ab70599cb2bc91a92b91859 (diff)
tools: Remove install-if-change program
The last installed tool in RTEMS repository is the install-if-change script. It is not used to build/install BSPs. This script does the same as the standard "install" program with an additional feature to install variants via the -V command line option. This script is used by the standard Makefile support: c/src/make/host.cfg.in:INSTALL_CHANGE=$(PROJECT_BIN)/install-if-change The INSTALL_CHANGE is used by: c/src/make/host.cfg.in:ifndef INSTALL_CHANGE c/src/make/host.cfg.in:INSTALL_CHANGE=$(PROJECT_BIN)/install-if-change c/src/make/host.cfg.in:INSTALL_VARIANT=$(INSTALL_CHANGE) -V "$(LIB_VARIANT)" Remove the support for variant installation and instead use the standard "install" program. This breaks application Makefiles using the standard Makefile support of RTEMS. Close #3455.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 0 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index d88964fca2..2de9af56a4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -32,21 +32,6 @@ RTEMS_ENABLE_RTEMS_DEBUG
RTEMS_ENABLE_PARAVIRT
RTEMS_ENABLE_DRVMGR
-## Check if there are valid tools install and in the path.
-RTEMS_CHECK_TOOL(RTEMS_CC,gcc)
-test -z "$RTEMS_CC" && AC_MSG_ERROR([no acceptable cc found in \$PATH])
-
-## NOTES:
-## * tools/build are host-native tools to be installed on the host.
-## * tools/cpu are host-native or host-cross-target-tools
-
-RTEMS_BUILD_CONFIG_SUBDIRS([tools/build])
-
-# Some BSPs carelessly apply these tools as build-tools
-AS_IF([test $host != $build],[
-RTEMS_HOST_CONFIG_SUBDIRS([tools/build])
-])
-
RTEMS_TARGET_CONFIG_SUBDIRS([c])
AC_CONFIG_FILES([Makefile])