summaryrefslogtreecommitdiff
path: root/contrib/crossrpms/rtems4.10/sh/rtems-4.10-sh-rtems4.10-gcc.spec
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/crossrpms/rtems4.10/sh/rtems-4.10-sh-rtems4.10-gcc.spec')
-rw-r--r--contrib/crossrpms/rtems4.10/sh/rtems-4.10-sh-rtems4.10-gcc.spec42
1 files changed, 17 insertions, 25 deletions
diff --git a/contrib/crossrpms/rtems4.10/sh/rtems-4.10-sh-rtems4.10-gcc.spec b/contrib/crossrpms/rtems4.10/sh/rtems-4.10-sh-rtems4.10-gcc.spec
index c0b1526748..3a887c1fa5 100644
--- a/contrib/crossrpms/rtems4.10/sh/rtems-4.10-sh-rtems4.10-gcc.spec
+++ b/contrib/crossrpms/rtems4.10/sh/rtems-4.10-sh-rtems4.10-gcc.spec
@@ -58,7 +58,7 @@ Summary: sh-rtems4.10 gcc
Group: Development/Tools
Version: %{gcc_rpmvers}
-Release: 2%{?dist}
+Release: 4%{?dist}
License: GPL
URL: http://gcc.gnu.org
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@@ -107,12 +107,6 @@ BuildRequires: %{_host_rpmprefix}gcc
%global gmp_provided 4.3.1
%endif
-%if 0%{?fc13}
-%global mpc_provided 0.8.1
-%global mpfr_provided 2.4.2
-%global gmp_provided 4.3.1
-%endif
-
%if 0%{?el6}
%global mpc_provided %{nil}
%global mpfr_provided 2.4.1
@@ -125,6 +119,12 @@ BuildRequires: %{_host_rpmprefix}gcc
%global gmp_provided 4.1.4
%endif
+%if 0%{?suse12_1}
+%global mpc_provided 0.8.2
+%global mpfr_provided 3.0.1
+%global gmp_provided 5.0.2
+%endif
+
%if 0%{?suse11_3}
%global mpc_provided 0.8.1
%global mpfr_provided 2.4.2
@@ -209,7 +209,6 @@ BuildRequires: %{_host_rpmprefix}libelf-devel >= %{libelf_required}
%if %{defined cloog_required}
-%{?fc13:BuildRequires: cloog-ppl-devel >= %cloog_required}
%{?fc14:BuildRequires: cloog-ppl-devel >= %cloog_required}
%{?fc15:BuildRequires: cloog-ppl-devel >= %cloog_required}
%{?fc16:BuildRequires: cloog-ppl-devel >= %cloog_required}
@@ -234,10 +233,9 @@ BuildRequires: %{_host_rpmprefix}mpfr-devel >= %{mpfr_required}
BuildRequires: rtems-4.10-sh-rtems4.10-gcc = %{gcc_rpmvers}
%endif
-%if "%{gcc_version}" >= "4.2.0"
+# Not strictly required, but patches may introduce a need to use them.
+# For reasons of simplicity, always require them.
BuildRequires: flex bison
-%endif
-
BuildRequires: texinfo >= 4.2
BuildRequires: rtems-4.10-sh-rtems4.10-binutils
@@ -245,7 +243,7 @@ BuildRequires: rtems-4.10-sh-rtems4.10-binutils
Requires: rtems-4.10-gcc-common
Requires: rtems-4.10-sh-rtems4.10-binutils
Requires: rtems-4.10-sh-rtems4.10-gcc-libgcc = %{gcc_rpmvers}-%{release}
-Requires: rtems-4.10-sh-rtems4.10-newlib = %{newlib_version}-25%{?dist}
+Requires: rtems-4.10-sh-rtems4.10-newlib = %{newlib_version}-27%{?dist}
%if "%{gcc_version}" >= "4.5.0"
BuildRequires: zlib-devel
@@ -257,21 +255,15 @@ BuildRequires: %{_host_rpmprefix}zlib-devel
%global _gcclibdir %{_prefix}/lib
-%if "%{gcc_version}" == "4.4.5"
-Source0: ftp://ftp.gnu.org/gnu/gcc/gcc-%{gcc_pkgvers}/gcc-core-%{gcc_pkgvers}.tar.bz2
-Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.10/gcc-core-4.4.5-rtems4.10-20110301.diff
-%endif
%if "%{gcc_version}" == "4.4.6"
Source0: ftp://ftp.gnu.org/gnu/gcc/gcc-%{gcc_pkgvers}/gcc-core-%{gcc_pkgvers}.tar.bz2
-Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.10/gcc-core-4.4.6-rtems4.10-20110420.diff
+Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.10/gcc-core-4.4.6-rtems4.10-20110829.diff
%endif
%{?_without_sources:NoSource: 0}
-%if "%{gcc_version}" == "4.4.5"
-Source1: ftp://ftp.gnu.org/gnu/gcc/gcc-%{gcc_pkgvers}/gcc-g++-%{gcc_pkgvers}.tar.bz2
-%endif
%if "%{gcc_version}" == "4.4.6"
Source1: ftp://ftp.gnu.org/gnu/gcc/gcc-%{gcc_pkgvers}/gcc-g++-%{gcc_pkgvers}.tar.bz2
+Patch1: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.10/gcc-g++-4.4.6-rtems4.10-20110829.diff
%endif
%{?_without_sources:NoSource: 1}
@@ -362,7 +354,7 @@ cd ..
ln -s ../libelf-%{libelf_version} gcc-%{gcc_pkgvers}/libelf
%endif
-echo "RTEMS gcc-%{gcc_version}-2%{?dist}/newlib-%{newlib_version}-25%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
+echo "RTEMS gcc-%{gcc_version}-4%{?dist}/newlib-%{newlib_version}-27%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
# Fix timestamps
@@ -635,7 +627,7 @@ sed -e 's,^[ ]*/usr/lib/rpm/find-debuginfo.sh,./find-debuginfo.sh,' \
# Group: Development/Tools
# Version: %{gcc_rpmvers}
# Requires: rtems-4.10-sh-rtems4.10-binutils
-# Requires: rtems-4.10-sh-rtems4.10-newlib = %{newlib_version}-25%{?dist}
+# Requires: rtems-4.10-sh-rtems4.10-newlib = %{newlib_version}-27%{?dist}
# License: GPL
# %if %build_infos
@@ -653,7 +645,7 @@ Summary: libgcc for sh-rtems4.10-gcc
Group: Development/Tools
Version: %{gcc_rpmvers}
%{?_with_noarch_subpackages:BuildArch: noarch}
-Requires: rtems-4.10-sh-rtems4.10-newlib = %{newlib_version}-25%{?dist}
+Requires: rtems-4.10-sh-rtems4.10-newlib = %{newlib_version}-27%{?dist}
License: GPL
%description -n rtems-4.10-sh-rtems4.10-gcc-libgcc
@@ -829,7 +821,7 @@ Summary: C Library (newlib) for sh-rtems4.10
Group: Development/Tools
License: Distributable
Version: %{newlib_version}
-Release: 25%{?dist}
+Release: 27%{?dist}
%{?_with_noarch_subpackages:BuildArch: noarch}
Requires: rtems-4.10-newlib-common
@@ -850,7 +842,7 @@ Newlib C Library for sh-rtems4.10.
Summary: Base package for RTEMS newlib C Library
Group: Development/Tools
Version: %{newlib_version}
-Release: 25%{?dist}
+Release: 27%{?dist}
%{?_with_noarch_subpackages:BuildArch: noarch}
License: Distributable