summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sprmsched01/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/sptests/sprmsched01/Makefile.am')
-rw-r--r--testsuites/sptests/sprmsched01/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/testsuites/sptests/sprmsched01/Makefile.am b/testsuites/sptests/sprmsched01/Makefile.am
new file mode 100644
index 0000000000..62d39c86c3
--- /dev/null
+++ b/testsuites/sptests/sprmsched01/Makefile.am
@@ -0,0 +1,21 @@
+
+rtems_tests_PROGRAMS = sprmsched01
+sprmsched01_SOURCES = init.c tasks.c system.h
+
+dist_rtems_tests_DATA = sprmsched01.scn
+dist_rtems_tests_DATA += sprmsched01.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(sprmsched01_OBJECTS)
+LINK_LIBS = $(sprmsched01_LDLIBS)
+
+sprmsched01$(EXEEXT): $(sprmsched01_OBJECTS) $(sprmsched01_DEPENDENCIES)
+ @rm -f sprmsched01$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am