summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/spfatal27/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/sptests/spfatal27/Makefile.am')
-rw-r--r--testsuites/sptests/spfatal27/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/testsuites/sptests/spfatal27/Makefile.am b/testsuites/sptests/spfatal27/Makefile.am
new file mode 100644
index 0000000000..744cef7541
--- /dev/null
+++ b/testsuites/sptests/spfatal27/Makefile.am
@@ -0,0 +1,21 @@
+rtems_tests_PROGRAMS = spfatal27
+spfatal27_SOURCES = ../spfatal_support/init.c \
+ ../spfatal_support/system.h testcase.h
+
+dist_rtems_tests_DATA = spfatal27.scn
+dist_rtems_tests_DATA += spfatal27.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(spfatal27_OBJECTS)
+LINK_LIBS = $(spfatal27_LDLIBS)
+
+spfatal27$(EXEEXT): $(spfatal27_OBJECTS) $(spfatal27_DEPENDENCIES)
+ @rm -f spfatal27$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am