summaryrefslogtreecommitdiffstats
path: root/testsuites/smptests/smpthreadlife01/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/smptests/smpthreadlife01/Makefile.am')
-rw-r--r--testsuites/smptests/smpthreadlife01/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/testsuites/smptests/smpthreadlife01/Makefile.am b/testsuites/smptests/smpthreadlife01/Makefile.am
new file mode 100644
index 0000000000..02b5bd542f
--- /dev/null
+++ b/testsuites/smptests/smpthreadlife01/Makefile.am
@@ -0,0 +1,19 @@
+rtems_tests_PROGRAMS = smpthreadlife01
+smpthreadlife01_SOURCES = init.c
+
+dist_rtems_tests_DATA = smpthreadlife01.scn smpthreadlife01.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(smpthreadlife01_OBJECTS)
+LINK_LIBS = $(smpthreadlife01_LDLIBS)
+
+smpthreadlife01$(EXEEXT): $(smpthreadlife01_OBJECTS) $(smpthreadlife01_DEPENDENCIES)
+ @rm -f smpthreadlife01$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am