summaryrefslogtreecommitdiffstats
path: root/testsuites/smptests/smpatomic06/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/smptests/smpatomic06/Makefile.am')
-rw-r--r--testsuites/smptests/smpatomic06/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/testsuites/smptests/smpatomic06/Makefile.am b/testsuites/smptests/smpatomic06/Makefile.am
index 30c23f7828..80f9d156c5 100644
--- a/testsuites/smptests/smpatomic06/Makefile.am
+++ b/testsuites/smptests/smpatomic06/Makefile.am
@@ -1,15 +1,16 @@
-
+if ATOMIC
rtems_tests_PROGRAMS = smpatomic06
smpatomic06_SOURCES = init.c tasks.c system.h ../../support/src/locked_print.c
dist_rtems_tests_DATA = smpatomic06.scn
dist_rtems_tests_DATA += smpatomic06.doc
+endif
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-
+if ATOMIC
AM_CPPFLAGS += -I$(top_srcdir)/../support/include
LINK_OBJS = $(smpatomic06_OBJECTS)
@@ -18,5 +19,6 @@ LINK_LIBS = $(smpatomic06_LDLIBS)
smpatomic06$(EXEEXT): $(smpatomic06_OBJECTS) $(smpatomic06_DEPENDENCIES)
@rm -f smpatomic06$(EXEEXT)
$(make-exe)
+endif
include $(top_srcdir)/../automake/local.am