summaryrefslogtreecommitdiffstats
path: root/testsuites/smptests/smpatomic02/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/smptests/smpatomic02/Makefile.am')
-rw-r--r--testsuites/smptests/smpatomic02/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/testsuites/smptests/smpatomic02/Makefile.am b/testsuites/smptests/smpatomic02/Makefile.am
index a7d9cbf073..d4b4d6aa32 100644
--- a/testsuites/smptests/smpatomic02/Makefile.am
+++ b/testsuites/smptests/smpatomic02/Makefile.am
@@ -1,15 +1,16 @@
-
+if ATOMIC
rtems_tests_PROGRAMS = smpatomic02
smpatomic02_SOURCES = init.c tasks.c system.h ../../support/src/locked_print.c
dist_rtems_tests_DATA = smpatomic02.scn
dist_rtems_tests_DATA += smpatomic02.doc
+endif
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-
+if ATOMIC
AM_CPPFLAGS += -I$(top_srcdir)/../support/include
LINK_OBJS = $(smpatomic02_OBJECTS)
@@ -18,5 +19,6 @@ LINK_LIBS = $(smpatomic02_LDLIBS)
smpatomic02$(EXEEXT): $(smpatomic02_OBJECTS) $(smpatomic02_DEPENDENCIES)
@rm -f smpatomic01$(EXEEXT)
$(make-exe)
+endif
include $(top_srcdir)/../automake/local.am