summaryrefslogtreecommitdiffstats
path: root/testsuites/rhealstone/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/rhealstone/Makefile.am')
-rw-r--r--testsuites/rhealstone/Makefile.am77
1 files changed, 69 insertions, 8 deletions
diff --git a/testsuites/rhealstone/Makefile.am b/testsuites/rhealstone/Makefile.am
index e2dcf694da..dd558445a9 100644
--- a/testsuites/rhealstone/Makefile.am
+++ b/testsuites/rhealstone/Makefile.am
@@ -1,12 +1,73 @@
+#
+# Real-time Benchmarking
+#
+
ACLOCAL_AMFLAGS = -I ../aclocal
-_SUBDIRS =
-_SUBDIRS += rhdeadlockbrk
-_SUBDIRS += rhilatency
-_SUBDIRS += rhmlatency
-_SUBDIRS += rhsemshuffle
-_SUBDIRS += rhtaskpreempt
-_SUBDIRS += rhtaskswitch
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+
+rhealstones =
+rhealstone_screens =
+rhealstone_docs =
+
+support_includes = -I$(top_srcdir)/../support/include
+
+if TEST_rhdeadlockbrk
+rhealstones += rhdeadlockbrk
+rhealstone_docs += rhdeadlockbrk/rhdeadlockbrk.adoc
+rhdeadlockbrk_SOURCES = rhdeadlockbrk/deadlockbrk.c \
+ ../tmtests/include/timesys.h
+rhdeadlockbrk_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_rhdeadlockbrk) \
+ $(support_includes) -I$(top_srcdir)/../tmtests/include
+endif
+
+if TEST_rhilatency
+rhealstones += rhilatency
+rhealstone_docs += rhilatency/rhilatency.adoc
+rhilatency_SOURCES = rhilatency/ilatency.c \
+ ../tmtests/include/timesys.h
+rhilatency_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_rhilatency) \
+ $(support_includes) -I$(top_srcdir)/../tmtests/include
+endif
+
+if TEST_rhmlatency
+rhealstones += rhmlatency
+rhealstone_docs += rhmlatency/rhmlatency.adoc
+rhmlatency_SOURCES = rhmlatency/mlatency.c \
+ ../tmtests/include/timesys.h
+rhmlatency_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_rhmlatency) \
+ $(support_includes) -I$(top_srcdir)/../tmtests/include
+endif
+
+if TEST_rhsemshuffle
+rhealstones += rhsemshuffle
+rhealstone_docs += rhsemshuffle/rhsemshuffle.adoc
+rhsemshuffle_SOURCES = rhsemshuffle/semshuffle.c \
+ ../tmtests/include/timesys.h
+rhsemshuffle_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_rhsemshuffle) \
+ $(support_includes) -I$(top_srcdir)/../tmtests/include
+endif
+
+if TEST_rhtaskpreempt
+rhealstones += rhtaskpreempt
+rhealstone_docs += rhtaskpreempt/rhtaskpreempt.adoc
+rhtaskpreempt_SOURCES = rhtaskpreempt/taskpreempt.c \
+ ../tmtests/include/timesys.h
+rhtaskpreempt_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_rhtaskpreempt) \
+ $(support_includes) -I$(top_srcdir)/../tmtests/include
+endif
+
+if TEST_rhtaskswitch
+rhealstones += rhtaskswitch
+rhealstone_docs += rhtaskswitch/rhtaskswitch.adoc
+rhtaskswitch_SOURCES = rhtaskswitch/taskswitch.c \
+ ../tmtests/include/timesys.h
+rhtaskswitch_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_rhtaskswitch) \
+ $(support_includes) -I$(top_srcdir)/../tmtests/include
+endif
+
+rtems_tests_PROGRAMS = $(rhealstones)
+dist_rtems_tests_DATA = $(rhealstone_screens) $(rhealstone_docs)
-include $(top_srcdir)/../automake/subdirs.am
include $(top_srcdir)/../automake/local.am