summaryrefslogtreecommitdiffstats
path: root/testsuites/libtests/sparsedisk01/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/libtests/sparsedisk01/Makefile.am')
-rw-r--r--testsuites/libtests/sparsedisk01/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/testsuites/libtests/sparsedisk01/Makefile.am b/testsuites/libtests/sparsedisk01/Makefile.am
new file mode 100644
index 0000000000..3a836c84a7
--- /dev/null
+++ b/testsuites/libtests/sparsedisk01/Makefile.am
@@ -0,0 +1,19 @@
+rtems_tests_PROGRAMS = sparsedisk01
+sparsedisk01_SOURCES = init.c
+
+dist_rtems_tests_DATA = sparsedisk01.scn sparsedisk01.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(sparsedisk01_OBJECTS)
+LINK_LIBS = $(sparsedisk01_LDLIBS)
+
+sparsedisk01$(EXEEXT): $(sparsedisk01_OBJECTS) $(sparsedisk01_DEPENDENCIES)
+ @rm -f sparsedisk01$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am