summaryrefslogtreecommitdiffstats
path: root/testsuites/libtests/mathl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/libtests/mathl/Makefile.am')
-rw-r--r--testsuites/libtests/mathl/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/testsuites/libtests/mathl/Makefile.am b/testsuites/libtests/mathl/Makefile.am
index b7a823460c..23d21d65c0 100644
--- a/testsuites/libtests/mathl/Makefile.am
+++ b/testsuites/libtests/mathl/Makefile.am
@@ -4,7 +4,14 @@ EXTRA_DIST = $(srcdir)/../math/domath.in
# FIXME: Skip long double, not yet supported in newlib
# => This test currently is a nop
-mathl_CPPFLAGS = $(AM_CPPFLAGS) -I$(top_srcdir)/math -DNO_LONG_DOUBLE
+mathl_CPPFLAGS = $(AM_CPPFLAGS) -DNO_LONG_DOUBLE
+
+$(srcdir)/domathl.c: $(srcdir)/../math/domath.in
+ sed -e 's,[@]FTYPE[@],long double,' \
+ -e 's,[@]FSUFFIX[@],l,g' \
+ -e 's,%f,%Lf,g' \
+ -e 's,[@]FGUARD[@],NO_LONG_DOUBLE,' \
+ $(srcdir)/../math/domath.in > $(srcdir)/domathl.c
dist_rtems_tests_DATA = mathl.scn