summaryrefslogtreecommitdiffstats
path: root/testsuites/libtests/math/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/libtests/math/Makefile.am')
-rw-r--r--testsuites/libtests/math/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/testsuites/libtests/math/Makefile.am b/testsuites/libtests/math/Makefile.am
index 835bd931a5..5a8a010810 100644
--- a/testsuites/libtests/math/Makefile.am
+++ b/testsuites/libtests/math/Makefile.am
@@ -1,5 +1,12 @@
rtems_tests_PROGRAMS = math
math_SOURCES = init.c domath.c
+EXTRA_DIST = $(srcdir)/../math/domath.in
+
+$(srcdir)/domath.c: $(srcdir)/../math/domath.in
+ sed -e 's,[@]FTYPE[@],double,' \
+ -e 's,[@]FSUFFIX[@], ,g' \
+ -e 's,[@]FGUARD[@],NO_DOUBLE,' \
+ $(srcdir)/../math/domath.in > $(srcdir)/domath.c
dist_rtems_tests_DATA = math.scn
@@ -7,7 +14,6 @@ include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-math_CPPFLAGS = $(AM_CPPFLAGS) -I$(top_srcdir)/math
math_LDADD = -lm
LINK_OBJS = $(math_OBJECTS) $(math_LDADD)