summaryrefslogtreecommitdiffstats
path: root/testsuites/benchmarks/linpack/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/benchmarks/linpack/Makefile.am')
-rw-r--r--testsuites/benchmarks/linpack/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/testsuites/benchmarks/linpack/Makefile.am b/testsuites/benchmarks/linpack/Makefile.am
index d947cd626b..2f5c25cf57 100644
--- a/testsuites/benchmarks/linpack/Makefile.am
+++ b/testsuites/benchmarks/linpack/Makefile.am
@@ -1,5 +1,6 @@
rtems_tests_PROGRAMS = linpack
-linpack_SOURCES = init.c
+linpack_SOURCES = init.c linpack-pc.c
+linpack_LDADD = -lm
dist_rtems_tests_DATA = linpack.scn linpack.doc
@@ -8,8 +9,9 @@ include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+AM_CFLAGS += -fno-inline -fno-builtin
-LINK_OBJS = $(linpack_OBJECTS)
+LINK_OBJS = $(linpack_OBJECTS) $(linpack_LDADD)
LINK_LIBS = $(linpack_LDLIBS)
linpack$(EXEEXT): $(linpack_OBJECTS) $(linpack_DEPENDENCIES)