summaryrefslogtreecommitdiffstats
path: root/testsuites/benchmarks/dhrystone/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/benchmarks/dhrystone/Makefile.am')
-rw-r--r--testsuites/benchmarks/dhrystone/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/testsuites/benchmarks/dhrystone/Makefile.am b/testsuites/benchmarks/dhrystone/Makefile.am
index 0354012a4a..73b67212aa 100644
--- a/testsuites/benchmarks/dhrystone/Makefile.am
+++ b/testsuites/benchmarks/dhrystone/Makefile.am
@@ -1,5 +1,5 @@
rtems_tests_PROGRAMS = dhrystone
-dhrystone_SOURCES = init.c
+dhrystone_SOURCES = init.c dhry_1.c dhry_2.c
dist_rtems_tests_DATA = dhrystone.scn dhrystone.doc
@@ -8,6 +8,7 @@ include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+AM_CFLAGS += -fno-inline -fno-builtin
LINK_OBJS = $(dhrystone_OBJECTS)
LINK_LIBS = $(dhrystone_LDLIBS)