summaryrefslogtreecommitdiffstats
path: root/doc/user/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/user/Makefile.am')
-rw-r--r--doc/user/Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/doc/user/Makefile.am b/doc/user/Makefile.am
index 7992b29005..1b6ddcb7e4 100644
--- a/doc/user/Makefile.am
+++ b/doc/user/Makefile.am
@@ -8,14 +8,14 @@ PROJECT = c_user
include $(top_srcdir)/project.am
include $(top_srcdir)/main.am
-FILES = bsp.texi dirstat.texi example.texi glossary.texi preface.texi
+FILES = bsp.texi example.texi glossary.texi preface.texi
GENERATED_FILES = overview.texi concepts.texi datatypes.texi init.texi \
task.texi intr.texi clock.texi timer.texi sem.texi msg.texi event.texi \
signal.texi part.texi region.texi dpmem.texi io.texi fatal.texi \
schedule.texi rtmon.texi barrier.texi bsp.texi userext.texi conf.texi \
mp.texi stackchk.texi cpuuse.texi object.texi chains.texi timespec.texi \
- cbs.texi
+ cbs.texi dirstat.texi
COMMON_FILES += $(top_srcdir)/common/cpright.texi
@@ -193,10 +193,15 @@ cbs.texi: cbs.t
-u "Top" \
-n "Directive Status Codes" < $< > $@
+dirstat.texi: dirstat.t
+ $(BMENU2) -p "Constant Bandwidth Server Scheduler API CBS_GET_APPROVED_BUDGET - Get scheduler approved execution time" \
+ -u "Top" \
+ -n "Example Application" < $< > $@
+
EXTRA_DIST = bsp.t cbs.t clock.t chains.t concepts.t cpuuse.t datatypes.t conf.t \
dpmem.t event.t fatal.t init.t intr.t io.t mp.t msg.t overview.t \
part.t region.t rtmon.t sem.t schedule.t signal.t stackchk.t \
- task.t timer.t userext.t $(TXT_FILES) $(PNG_FILES) $(EPS_IMAGES) \
+ task.t timer.t userext.t dirstat.t $(TXT_FILES) $(PNG_FILES) $(EPS_IMAGES) \
$(noinst_DATA)
CLEANFILES += c_user.info c_user.info-? c_user.info-??