summaryrefslogtreecommitdiffstats
path: root/doc/user/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/user/Makefile.am')
-rw-r--r--doc/user/Makefile.am13
1 files changed, 9 insertions, 4 deletions
diff --git a/doc/user/Makefile.am b/doc/user/Makefile.am
index e7743199df..cd8b5f3f4d 100644
--- a/doc/user/Makefile.am
+++ b/doc/user/Makefile.am
@@ -14,8 +14,8 @@ GENERATED_FILES = overview.texi concepts.texi datatypes.texi init.texi \
task.texi intr.texi clock.texi timer.texi sem.texi msg.texi event.texi \
signal.texi part.texi region.texi dpmem.texi io.texi fatal.texi \
schedule.texi rtmon.texi barrier.texi bsp.texi userext.texi conf.texi \
- mp.texi stackchk.texi cpuuse.texi object.texi chains.texi timespec.texi \
- cbs.texi dirstat.texi smp.texi
+ mp.texi stackchk.texi cpuuse.texi object.texi chains.texi rbtree.texi \
+ timespec.texi cbs.texi dirstat.texi smp.texi
COMMON_FILES += $(top_srcdir)/common/cpright.texi
@@ -186,10 +186,15 @@ object.texi: object.t
chains.texi: chains.t
$(BMENU2) -p "Object Services OBJECT_GET_CLASS_INFORMATION - Obtain Class Information" \
-u "Top" \
+ -n "Red-Black Trees" < $< > $@
+
+rbtree.texi: rbtree.t
+ $(BMENU2) -p "Chains Prepend a Node" \
+ -u "Top" \
-n "Timespec Helpers" < $< > $@
timespec.texi: timespec.t
- $(BMENU2) -p "Chains Prepend a Node" \
+ $(BMENU2) -p "Red-Black Trees Documentation for the Red-Black Tree Directives" \
-u "Top" \
-n "Constant Bandwidth Server Scheduler API" < $< > $@
@@ -205,7 +210,7 @@ dirstat.texi: dirstat.t
EXTRA_DIST = bsp.t cbs.t clock.t chains.t concepts.t cpuuse.t datatypes.t conf.t \
dpmem.t event.t fatal.t init.t intr.t io.t mp.t msg.t overview.t \
- part.t region.t rtmon.t sem.t schedule.t signal.t stackchk.t \
+ part.t rbtree.t region.t rtmon.t sem.t schedule.t signal.t stackchk.t \
task.t timer.t userext.t dirstat.t $(TXT_FILES) $(PNG_FILES) $(EPS_IMAGES) \
$(noinst_DATA)