summaryrefslogtreecommitdiffstats
path: root/cpukit/libdl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/libdl/Makefile.am')
-rw-r--r--cpukit/libdl/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/cpukit/libdl/Makefile.am b/cpukit/libdl/Makefile.am
new file mode 100644
index 0000000000..11f1478522
--- /dev/null
+++ b/cpukit/libdl/Makefile.am
@@ -0,0 +1,36 @@
+if LIBDL
+
+include $(top_srcdir)/automake/compile.am
+
+noinst_LIBRARIES = libdl.a
+libdl_a_SOURCES = \
+ dlfcn-shell.c \
+ dlfcn.c \
+ fastlz.c \
+ rap-shell.c \
+ rap.c \
+ rtl.c \
+ rtl-alloc-heap.c \
+ rtl-allocator.c \
+ rtl-chain-iterator.c \
+ rtl-debugger.c \
+ rtl-elf.c \
+ rtl-error.c \
+ rtl-find-file.c \
+ rtl-obj-cache.c \
+ rtl-obj-comp.c \
+ rtl-obj.c \
+ rtl-rap.c \
+ rtl-shell.c \
+ rtl-string.c \
+ rtl-sym.c \
+ rtl-trace.c \
+ rtl-unresolved.c
+
+libdl_a_SOURCES += rtl-mdreloc-@RTEMS_CPU@.c
+libdl_a_CPPFLAGS = $(AM_CPPFLAGS) -DRTEMS_RTL_RAP_LOADER=1 -DRTEMS_RTL_ELF_LOADER=1
+
+include $(srcdir)/preinstall.am
+include $(top_srcdir)/automake/local.am
+
+endif