summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index 56815e224a..fcf3437a1b 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -116,6 +116,12 @@ RTEMS_CHECK_FUNC([pthread_getattr_np],[
#include <pthread.h>])
AC_CHECK_HEADERS([sys/cpuset.h])
+# This was added to newlib in August 2014 to improve conformance.
+# Disable use of internal definition if it is present.
+RTEMS_CHECK_FUNC([sigaltstack],[
+ #define _GNU_SOURCE
+ #include <signal.h>])
+
# Mandated by POSIX, not declared in some versions of newlib.
AC_CHECK_DECLS([getrusage],,,[#include sys/resource.h])
@@ -236,6 +242,12 @@ RTEMS_CPUOPT([__RTEMS_HAVE_SYS_CPUSET_H__],
[1],
[indicate if <sys/cpuset.h> is present in toolset])
+## Header file differences that need to be known in .h after install
+RTEMS_CPUOPT([__RTEMS_HAVE_DECL_SIGALTSTACK__],
+ [test x"${ac_cv_have_decl_sigaltstack}" = x"yes"],
+ [1],
+ [indicate if <signal.h> in toolset has sigaltstack()])
+
## This improves both the size and coverage analysis.
RTEMS_CPUOPT([__RTEMS_DO_NOT_INLINE_THREAD_ENABLE_DISPATCH__],
[test x"${RTEMS_DO_NOT_INLINE_THREAD_ENABLE_DISPATCH}" = x"1"],