summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index 51944da950..9e02e37959 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -624,7 +624,6 @@ _SUBDIRS += wrapup
_SUBDIRS += zlib
_SUBDIRS += telnetd
_SUBDIRS += pppd
-_SUBDIRS += mghttpd
project_lib_LIBRARIES += libftpd.a
@@ -703,6 +702,19 @@ libnfs_a_SOURCES += libfs/src/nfsclient/src/rpcio.c
libnfs_a_SOURCES += libfs/src/nfsclient/src/sock_mbuf.c
libnfs_a_SOURCES += libfs/src/nfsclient/src/xdr_mbuf.c
+if HAS_PTHREADS
+
+project_lib_LIBRARIES += libmghttpd.a
+
+$(PROJECT_LIB)/libmghttpd.a: libmghttpd.a
+ $(INSTALL_DATA) $< $(PROJECT_LIB)/libmghttpd.a
+TMPINSTALL_FILES += $(PROJECT_LIB)/libmghttpd.a
+
+libmghttpd_a_SOURCES =
+libmghttpd_a_SOURCES += mghttpd/mongoose.c
+
+endif
+
endif
include $(top_srcdir)/automake/subdirs.am