summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp39/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2008-01-07 15:07:47 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2008-01-07 15:07:47 +0000
commitfa9889742a14b5095e03cb63a02b2caf12d11494 (patch)
treee69583e12d9258985ebcac5dedb6cf0dfba11a5f /testsuites/sptests/sp39/Makefile.am
parent2008-01-05 Chris Johns <chrisj@rtems.org> (diff)
downloadrtems-fa9889742a14b5095e03cb63a02b2caf12d11494.tar.bz2
2008-01-07 Joel Sherrill <joel.sherrill@oarcorp.com>
* Makefile.am, configure.ac: Added sp38 and sp39. * sp38/.cvsignore, sp38/Makefile.am, sp38/init.c, sp38/sp38.scn, sp38/system.h, sp39/.cvsignore, sp39/Makefile.am, sp39/init.c, sp39/sp39.scn, sp39/system.h: New files.
Diffstat (limited to 'testsuites/sptests/sp39/Makefile.am')
-rw-r--r--testsuites/sptests/sp39/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/testsuites/sptests/sp39/Makefile.am b/testsuites/sptests/sp39/Makefile.am
new file mode 100644
index 0000000000..ea19315aa9
--- /dev/null
+++ b/testsuites/sptests/sp39/Makefile.am
@@ -0,0 +1,27 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = sp39.exe
+sp39_exe_SOURCES = init.c system.h
+
+dist_rtems_tests_DATA = sp39.scn
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+sp39_exe_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(sp39_exe_OBJECTS) $(sp39_exe_LDADD)
+LINK_LIBS = $(sp39_exe_LDLIBS)
+
+sp39.exe$(EXEEXT): $(sp39_exe_OBJECTS) $(sp39_exe_DEPENDENCIES)
+ @rm -f sp39.exe$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am