summaryrefslogtreecommitdiffstats
path: root/testsuites/smptests/smpschedaffinity05/Makefile.am
diff options
context:
space:
mode:
authorJennifer Averett <jennifer.averett@oarcorp.com>2014-07-10 11:45:58 -0500
committerJennifer Averett <jennifer.averett@oarcorp.com>2014-07-11 10:12:48 -0500
commit7eb3fd4782e57cb8b23d43c912c132c01783852a (patch)
tree9429733bba177289b1abc8c808b1793b8d3a7fd5 /testsuites/smptests/smpschedaffinity05/Makefile.am
parentsmpschedaffinity04: New test. (diff)
downloadrtems-7eb3fd4782e57cb8b23d43c912c132c01783852a.tar.bz2
smpschedaffinity05: Add test for worst case migration for affintiy scheduler.
This test uses a combination of priority and affinity to cause the tasks running on all 4 cores to change due to one task priority change.
Diffstat (limited to 'testsuites/smptests/smpschedaffinity05/Makefile.am')
-rw-r--r--testsuites/smptests/smpschedaffinity05/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/testsuites/smptests/smpschedaffinity05/Makefile.am b/testsuites/smptests/smpschedaffinity05/Makefile.am
new file mode 100644
index 0000000000..2577ba6a48
--- /dev/null
+++ b/testsuites/smptests/smpschedaffinity05/Makefile.am
@@ -0,0 +1,19 @@
+rtems_tests_PROGRAMS = smpschedaffinity05
+smpschedaffinity05_SOURCES = init.c
+
+dist_rtems_tests_DATA = smpschedaffinity05.scn smpschedaffinity05.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(smpschedaffinity05_OBJECTS)
+LINK_LIBS = $(smpschedaffinity05_LDLIBS)
+
+smpschedaffinity05$(EXEEXT): $(smpschedaffinity05_OBJECTS) $(smpschedaffinity05_DEPENDENCIES)
+ @rm -f smpschedaffinity05$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am