summaryrefslogtreecommitdiffstats
path: root/testsuites/smptests/smplock01/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2013-05-29 10:41:18 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2013-05-31 15:20:32 +0200
commitbbed18668fbf78b5728ec4dc42c35565e3451165 (patch)
tree913b36d184d943152f7bb28e7cdb4cd7244b38f6 /testsuites/smptests/smplock01/Makefile.am
parentsmp: New SMP lock API (diff)
downloadrtems-bbed18668fbf78b5728ec4dc42c35565e3451165.tar.bz2
smptests/smplock01: New test
Diffstat (limited to 'testsuites/smptests/smplock01/Makefile.am')
-rw-r--r--testsuites/smptests/smplock01/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/testsuites/smptests/smplock01/Makefile.am b/testsuites/smptests/smplock01/Makefile.am
new file mode 100644
index 0000000000..05bffe69c5
--- /dev/null
+++ b/testsuites/smptests/smplock01/Makefile.am
@@ -0,0 +1,19 @@
+rtems_tests_PROGRAMS = smplock01
+smplock01_SOURCES = init.c
+
+dist_rtems_tests_DATA = smplock01.scn smplock01.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(smplock01_OBJECTS)
+LINK_LIBS = $(smplock01_LDLIBS)
+
+smplock01$(EXEEXT): $(smplock01_OBJECTS) $(smplock01_DEPENDENCIES)
+ @rm -f smplock01$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am