summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/psxcond01/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2009-07-21 15:07:26 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2009-07-21 15:07:26 +0000
commit14d3ad4fcfbd04593482254b4371b6630ab4d6a3 (patch)
tree30844c0b61384b7730662419f3a57d86296360c3 /testsuites/psxtests/psxcond01/Makefile.am
parent2009-07-21 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-14d3ad4fcfbd04593482254b4371b6630ab4d6a3.tar.bz2
2009-07-21 Joel Sherrill <joel.sherrill@oarcorp.com>
* Makefile.am, configure.ac: Add new test to exercise error case for when a task is blocked on a condition variable with one mutex and another task attempts to block on the same condition variable with another mutex. * psxcond01/.cvsignore, psxcond01/Makefile.am, psxcond01/init.c, psxcond01/psxcond01.doc, psxcond01/psxcond01.scn: New files.
Diffstat (limited to 'testsuites/psxtests/psxcond01/Makefile.am')
-rw-r--r--testsuites/psxtests/psxcond01/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/testsuites/psxtests/psxcond01/Makefile.am b/testsuites/psxtests/psxcond01/Makefile.am
new file mode 100644
index 0000000000..605e67fa73
--- /dev/null
+++ b/testsuites/psxtests/psxcond01/Makefile.am
@@ -0,0 +1,30 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = psxcond01
+psxcond01_SOURCES = init.c ../include/pmacros.h
+
+dist_rtems_tests_DATA = psxcond01.scn
+dist_rtems_tests_DATA += psxcond01.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+psxcond01_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+
+AM_CPPFLAGS += -I$(top_srcdir)/include
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(psxcond01_OBJECTS) $(psxcond01_LDADD)
+LINK_LIBS = $(psxcond01_LDLIBS)
+
+psxcond01$(EXEEXT): $(psxcond01_OBJECTS) \
+ $(psxcond01_DEPENDENCIES)
+ @rm -f psxcond01$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am