summaryrefslogtreecommitdiffstats
path: root/testsuites/libtests/block13/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2012-05-31 10:27:29 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2012-06-04 09:54:31 +0200
commit39ee704e757268de833ffb956dda28f6aa2fa3a1 (patch)
tree3bfd4e6ebc6dc48d3751ad8445206409720d9abd /testsuites/libtests/block13/Makefile.am
parentbsps/powerpc: Add load section for .nocache (diff)
downloadrtems-39ee704e757268de833ffb956dda28f6aa2fa3a1.tar.bz2
libblock: Add read-ahead task
Read-ahead requests were previously executed in the context of the reading task. This blocks the reading task until the complete read with read-ahead transfer is finished. A read-ahead task is introduced to off-load the read-ahead transfer. This allows the reading task to work with the requested block more quickly. The read-ahead is triggered after two misses of ascending consecutive blocks or a read hit of a block read by the most-recent read-ahead transfer. The read-ahead feature is configurable and can be disabled.
Diffstat (limited to 'testsuites/libtests/block13/Makefile.am')
-rw-r--r--testsuites/libtests/block13/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/testsuites/libtests/block13/Makefile.am b/testsuites/libtests/block13/Makefile.am
new file mode 100644
index 0000000000..9b4a76d0eb
--- /dev/null
+++ b/testsuites/libtests/block13/Makefile.am
@@ -0,0 +1,19 @@
+rtems_tests_PROGRAMS = block13
+block13_SOURCES = init.c
+
+dist_rtems_tests_DATA = block13.scn block13.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(block13_OBJECTS)
+LINK_LIBS = $(block13_LDLIBS)
+
+block13$(EXEEXT): $(block13_OBJECTS) $(block13_DEPENDENCIES)
+ @rm -f block13$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am