summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/psim/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2008-09-29 20:52:22 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2008-09-29 20:52:22 +0000
commit81ec50442dacc498cc69106cbec689028f2094df (patch)
tree076d631792c5306c5f0b71447922bab7b17175b1 /c/src/lib/libbsp/powerpc/psim/Makefile.am
parent2008-09-29 Ralf Corsépius <ralf.corsepius@rtems.org> (diff)
downloadrtems-81ec50442dacc498cc69106cbec689028f2094df.tar.bz2
2008-09-29 Ralf Corsépius <ralf.corsepius@rtems.org>
* Makefile.am: Eliminate bsp.am. Build startup files as side-effect of building libbspstart.a, using automake-rules.
Diffstat (limited to 'c/src/lib/libbsp/powerpc/psim/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/psim/Makefile.am21
1 files changed, 7 insertions, 14 deletions
diff --git a/c/src/lib/libbsp/powerpc/psim/Makefile.am b/c/src/lib/libbsp/powerpc/psim/Makefile.am
index 80987ddd1b..3392da5915 100644
--- a/c/src/lib/libbsp/powerpc/psim/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/psim/Makefile.am
@@ -4,12 +4,9 @@
ACLOCAL_AMFLAGS = -I ../../../../aclocal
-# wrapup is the one that actually builds and installs the library
-# from the individual .rel files built in other directories
SUBDIRS = . tools
include $(top_srcdir)/../../../../automake/compile.am
-include $(top_srcdir)/../../bsp.am
include_bspdir = $(includedir)/bsp
@@ -25,19 +22,16 @@ DISTCLEANFILES = include/bspopts.h
include_HEADERS += include/coverhd.h
-EXTRA_DIST = start/start.S
-start.$(OBJEXT): start/start.S
- $(CPPASCOMPILE) -o $@ -c $<
+noinst_LIBRARIES = libbspstart.a
+libbspstart_a_SOURCES = start/start.S
project_lib_DATA = start.$(OBJEXT)
-EXTRA_DIST += ../../powerpc/shared/start/rtems_crti.S
-rtems_crti.$(OBJEXT): ../../powerpc/shared/start/rtems_crti.S
- $(CPPASCOMPILE) -o $@ -c $<
+libbspstart_a_SOURCES += ../../powerpc/shared/start/rtems_crti.S
project_lib_DATA += rtems_crti.$(OBJEXT)
dist_project_lib_DATA += startup/linkcmds
-noinst_LIBRARIES = libbsp.a
+noinst_LIBRARIES += libbsp.a
libbsp_a_SOURCES =
# startup
@@ -55,11 +49,11 @@ libbsp_a_SOURCES += ../../shared/console-polled.c
# debugio
libbsp_a_SOURCES += console/console-io.c console/consupp.S
-include_bsp_HEADERS = irq/irq.h
# irq
+include_bsp_HEADERS = irq/irq.h
libbsp_a_SOURCES += irq/irq_init.c irq/no_pic.c
-EXTRA_DIST += vectors/README
+EXTRA_DIST = vectors/README
# vectors
libbsp_a_SOURCES += vectors/align_h.S
@@ -68,9 +62,8 @@ include_bsp_HEADERS += \
../../../libcpu/@RTEMS_CPU@/@exceptions@/bspsupport/irq_supp.h \
../../../libcpu/@RTEMS_CPU@/@exceptions@/bspsupport/ppc_exc_bspsupp.h
-if HAS_MP
EXTRA_DIST += shmsupp/README
-
+if HAS_MP
# shmdr
libbsp_a_SOURCES += \
shmsupp/addrconv.c shmsupp/getcfg.c shmsupp/lock.c shmsupp/mpisr.c