summaryrefslogtreecommitdiffstats
path: root/schedsim/shell/shared/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'schedsim/shell/shared/Makefile.am')
-rw-r--r--schedsim/shell/shared/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/schedsim/shell/shared/Makefile.am b/schedsim/shell/shared/Makefile.am
index 5b80e65..85b58af 100644
--- a/schedsim/shell/shared/Makefile.am
+++ b/schedsim/shell/shared/Makefile.am
@@ -49,6 +49,10 @@ libschedsim_a_SOURCES += main_taskwakeafter.c
libschedsim_a_SOURCES += schedsim_disable_dispatch.c
libschedsim_a_SOURCES += shell_cmdset.c
libschedsim_a_SOURCES += shell_makeargs.c
+if HAS_SMP
+libschedsim_a_SOURCES += main_taskgetaffinity.c
+libschedsim_a_SOURCES += main_tasksetaffinity.c
+endif
schedsim_shell_includedir = $(includedir)/schedsim
schedsim_newlib_includedir = $(includedir)/schedsim/newlib