summaryrefslogtreecommitdiffstats
path: root/schedsim/shell/schedsim_priority/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'schedsim/shell/schedsim_priority/Makefile.am')
-rw-r--r--schedsim/shell/schedsim_priority/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/schedsim/shell/schedsim_priority/Makefile.am b/schedsim/shell/schedsim_priority/Makefile.am
index 32febc6..378aea2 100644
--- a/schedsim/shell/schedsim_priority/Makefile.am
+++ b/schedsim/shell/schedsim_priority/Makefile.am
@@ -26,7 +26,16 @@ schedsim_priority_CPPFLAGS += -I$(cpukitdir)/posix/include
schedsim_priority_CPPFLAGS += -I$(cpukitdir)/posix/inline
endif
-schedsim_priority_LDFLAGS =-Wl,--wrap=_Thread_Dispatch
+## Ensure all linker provided symbols are available
+schedsim_priority_LDFLAGS =
+schedsim_priority_LDFLAGS += -Wl,--defsym=_TLS_Data_begin=0
+schedsim_priority_LDFLAGS += -Wl,--defsym=_TLS_BSS_end=0
+schedsim_priority_LDFLAGS += -Wl,--defsym=_TLS_Alignment=4
+
+## Wrap _Thread_Dispatch so we can see context switches
+schedsim_priority_LDFLAGS += -Wl,--wrap=_Thread_Dispatch
+
+## Link in all support libraries
## schedsim_priorityLDADD +=-Wl,--start-group
schedsim_priority_LDADD = ../shared/libschedsim.a
schedsim_priority_LDADD += ../../rtems/librtems.a