summaryrefslogtreecommitdiffstats
path: root/tools/update/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--tools/update/Makefile.am25
1 files changed, 7 insertions, 18 deletions
diff --git a/tools/update/Makefile.am b/tools/update/Makefile.am
index 05a1bf959e..6277439559 100644
--- a/tools/update/Makefile.am
+++ b/tools/update/Makefile.am
@@ -4,6 +4,7 @@
AUTOMAKE_OPTIONS = foreign 1.4
ACLOCAL_AMFLAGS = -I $(RTEMS_TOPdir)/aclocal
+
## NOTE: It doesn't make much sense to install these files
CLEANFILES = update word-replace
@@ -12,16 +13,10 @@ if PERL
# All files in this directory depend on having perl.
# Do not handle them if perl is missing.
-noinst_SCRIPTS = \
-acpolish \
-ampolish \
-cipolish \
-rtems-polish.sh \
-word-replace \
-update
+noinst_SCRIPTS = acpolish ampolish cipolish rtems-polish.sh word-replace \
+ update
-noinst_DATA = \
-310_to_320_list
+noinst_DATA = 310_to_320_list
update: $(srcdir)/update.in $(top_builddir)/config.status
@cd $(top_builddir) \
@@ -35,13 +30,7 @@ word-replace: $(srcdir)/word-replace.in $(top_builddir)/config.status
endif
-EXTRA_DIST = \
-310_to_320_list \
-update.in \
-word-replace.in \
-acpolish \
-ampolish \
-cipolish \
-rtems-polish.sh
+EXTRA_DIST = 310_to_320_list update.in word-replace.in acpolish ampolish \
+ cipolish rtems-polish.sh
-include $(top_srcdir)/../../automake/local.am
+include $(top_srcdir)/../../automake/host.am