summaryrefslogtreecommitdiffstats
path: root/tools/cpu/unix/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--tools/cpu/unix/Makefile.am20
1 files changed, 3 insertions, 17 deletions
diff --git a/tools/cpu/unix/Makefile.am b/tools/cpu/unix/Makefile.am
index 65147c0a2b..9c7367d149 100644
--- a/tools/cpu/unix/Makefile.am
+++ b/tools/cpu/unix/Makefile.am
@@ -2,25 +2,11 @@
# $Id$
#
-AUTOMAKE_OPTIONS = foreign
-ACLOCAL = @ACLOCAL@ -I $(RTEMS_TOPdir)/aclocal
+AUTOMAKE_OPTIONS = foreign 1.4
+ACLOCAL_AMFLAGS = -I $(RTEMS_TOPdir)/aclocal
noinst_PROGRAMS=gensize
gensize_SOURCES=gensize.c
-# We use files that have not been installed yet.
-CPU_DIR=$(srcdir)/../../cpu/$(RTEMS_CPU)
-
-INCLUDES = \
--I$(PROJECT_ROOT)/${RTEMS_BSP}/include \
--I$(CPU_DIR)
-
-# HACK: install into the build-tree
-preinstall: install-exec-local
-
-install-exec-local: gensize
- $(mkinstalldirs) $(PROJECT_ROOT)/${RTEMS_BSP}/bin
- $(INSTALL_PROGRAM) gensize $(PROJECT_ROOT)/${RTEMS_BSP}/bin
-
-include $(top_srcdir)/../../../../../../automake/local.am
+include $(top_srcdir)/../../../automake/local.am