summaryrefslogtreecommitdiffstats
path: root/tools/cpu/sh/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'tools/cpu/sh/configure.ac')
-rw-r--r--tools/cpu/sh/configure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/tools/cpu/sh/configure.ac b/tools/cpu/sh/configure.ac
new file mode 100644
index 0000000000..82fae15f96
--- /dev/null
+++ b/tools/cpu/sh/configure.ac
@@ -0,0 +1,25 @@
+## Process this file with autoconf to produce a configure script.
+##
+## $Id$
+
+AC_PREREQ([2.68])
+AC_INIT([rtems-tools-cpu-sh],[_RTEMS_VERSION],[http://www.rtems.org/bugzilla])
+AC_CONFIG_SRCDIR([shgen.c])
+RTEMS_TOP(../../..)
+
+RTEMS_CANONICAL_TARGET_CPU
+
+AM_INIT_AUTOMAKE([foreign 1.11.1])
+AM_MAINTAINER_MODE
+
+AC_PROG_CC
+AC_CHECK_LIB(m,fabs)
+AC_CHECK_FUNCS(getopt_long)
+AC_CHECK_PROGS(HELP2MAN,help2man)
+AM_CONDITIONAL(HELP2MAN,test -n "$HELP2MAN" )
+
+RTEMS_TOOLPATHS
+
+# Explicitly list all Makefiles here
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT