summaryrefslogtreecommitdiffstats
path: root/tools/cpu/hppa1.1/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--tools/cpu/hppa1.1/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/tools/cpu/hppa1.1/Makefile.am b/tools/cpu/hppa1.1/Makefile.am
new file mode 100644
index 0000000000..16063eaeb7
--- /dev/null
+++ b/tools/cpu/hppa1.1/Makefile.am
@@ -0,0 +1,28 @@
+#
+# $Id$
+#
+
+AUTOMAKE_OPTIONS = foreign
+ACLOCAL = @ACLOCAL@ -I $(RTEMS_TOPdir)/aclocal
+
+noinst_PROGRAMS=genoffsets
+
+genoffsets_SOURCES = \
+genoffsets.c
+
+# We use files that have not been installed yet.
+
+CPU_DIR=../../cpu/$(RTEMS_CPU)
+
+INCLUDES = \
+-I$(PROJECT_INCLUDE) \
+-I$(CPU_DIR)
+
+# HACK: install to build-tree
+preinstall: install-exec-local
+
+install-exec-local: genoffsets
+ $(mkinstalldirs) $(PROJECT_ROOT)/${RTEMS_BSP}/bin
+ $(INSTALL_PROGRAM) genoffsets ${PROJECT_ROOT}/${RTEMS_BSP}/bin
+
+include $(top_srcdir)/../../../../../../automake/local.am