summaryrefslogtreecommitdiffstats
path: root/tools/cpu/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'tools/cpu/configure.ac')
-rw-r--r--tools/cpu/configure.ac28
1 files changed, 28 insertions, 0 deletions
diff --git a/tools/cpu/configure.ac b/tools/cpu/configure.ac
new file mode 100644
index 0000000000..f5ae63bfbf
--- /dev/null
+++ b/tools/cpu/configure.ac
@@ -0,0 +1,28 @@
+## Process this file with autoconf to produce a configure script.
+##
+## $Id$
+
+AC_PREREQ([2.68])
+AC_INIT([rtems-tools-cpu],[_RTEMS_VERSION],[http://www.rtems.org/bugzilla])
+AC_CONFIG_SRCDIR([generic])
+RTEMS_TOP(../..)
+
+RTEMS_CANONICAL_TARGET_CPU
+
+AM_INIT_AUTOMAKE([no-define foreign 1.11.1])
+AM_MAINTAINER_MODE
+
+RTEMS_PATH_KSH
+
+RTEMS_TOOLPATHS
+AC_SUBST(program_prefix)
+
+AC_CONFIG_SUBDIRS(generic)
+case "$RTEMS_CPU" in
+sh ) AC_CONFIG_SUBDIRS(sh);;
+nios2 ) AC_CONFIG_SUBDIRS(nios2);;
+esac
+
+# Explicitly list all Makefiles here
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT