summaryrefslogtreecommitdiffstats
path: root/tools/build/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'tools/build/configure.ac')
-rw-r--r--tools/build/configure.ac26
1 files changed, 26 insertions, 0 deletions
diff --git a/tools/build/configure.ac b/tools/build/configure.ac
new file mode 100644
index 0000000000..d24f3e2d5a
--- /dev/null
+++ b/tools/build/configure.ac
@@ -0,0 +1,26 @@
+#
+# $Id$
+#
+
+AC_PREREQ([2.68])
+AC_INIT([rtems-tools-build],[_RTEMS_VERSION],[http://www.rtems.org/bugzilla])
+AC_CONFIG_SRCDIR([install-if-change.in])
+RTEMS_TOP(../..)
+
+AC_CANONICAL_HOST
+
+AM_INIT_AUTOMAKE([no-define foreign 1.11.1])
+AM_MAINTAINER_MODE
+
+AC_PROG_CC
+AC_CHECK_HEADERS([getopt.h libgen.h])
+AC_CHECK_FUNCS(strerror strtol basename)
+
+RTEMS_PATH_KSH
+
+AC_CONFIG_HEADERS([config.h])
+
+# Explicitly list all Makefiles here
+AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([install-if-change],[chmod +x install-if-change])
+AC_OUTPUT