summaryrefslogtreecommitdiffstats
path: root/tools/build/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--tools/build/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/tools/build/Makefile.am b/tools/build/Makefile.am
new file mode 100644
index 0000000000..f58624929f
--- /dev/null
+++ b/tools/build/Makefile.am
@@ -0,0 +1,26 @@
+##
+## $Id$
+##
+
+ACLOCAL_AMFLAGS = -I ../../aclocal
+
+bin_PROGRAMS = cklength eolstrip packhex unhex rtems-bin2c
+
+noinst_PROGRAMS = binpatch
+
+cklength_SOURCES = cklength.c
+eolstrip_SOURCES = eolstrip.c
+packhex_SOURCES = packhex.c
+unhex_SOURCES = unhex.c
+binpatch_SOURCES = binpatch.c
+rtems_bin2c_SOURCES = rtems-bin2c.c
+
+bin_SCRIPTS = install-if-change
+
+noinst_SCRIPTS = search-id.sh multigen cvsignore-add.sh
+EXTRA_DIST = search-id.sh multigen cvsignore-add.sh
+
+noinst_SCRIPTS += doxy-filter
+EXTRA_DIST += doxy-filter
+
+include $(top_srcdir)/../../automake/host.am