summaryrefslogtreecommitdiffstats
path: root/tools/build/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/build/Makefile.am')
-rw-r--r--tools/build/Makefile.am20
1 files changed, 2 insertions, 18 deletions
diff --git a/tools/build/Makefile.am b/tools/build/Makefile.am
index 97374498b8..ed0be76b44 100644
--- a/tools/build/Makefile.am
+++ b/tools/build/Makefile.am
@@ -2,8 +2,8 @@
# $Id$
#
-AUTOMAKE_OPTIONS = foreign
-ACLOCAL = @ACLOCAL@ -I $(RTEMS_TOPdir)/aclocal
+AUTOMAKE_OPTIONS = foreign 1.4
+ACLOCAL_AMFLAGS = -I $(RTEMS_TOPdir)/aclocal
bin_PROGRAMS=cklength eolstrip packhex unhex
@@ -20,20 +20,4 @@ rcs-clean
noinst_SCRIPTS = search-id.sh
-#
-# HACK: Install to build directory
-#
-install-exec-local: $(bin_PROGRAMS) $(bin_SCRIPTS)
- if test -n "${RTEMS_BSP}"; then \
- $(mkinstalldirs) $(PROJECT_ROOT)/${RTEMS_BSP}/build-tools; \
- for i in $(bin_SCRIPTS); do \
- $(INSTALL_SCRIPT) $$i $(PROJECT_ROOT)/${RTEMS_BSP}/build-tools; \
- done; \
- for i in $(bin_PROGRAMS); do \
- $(INSTALL_PROGRAM) $$i $(PROJECT_ROOT)/${RTEMS_BSP}/build-tools; \
- done; \
- fi
-
-preinstall: install-exec-local
-
include $(top_srcdir)/../../automake/local.am