summaryrefslogtreecommitdiffstats
path: root/testsuites/tools/generic/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--testsuites/tools/generic/Makefile.am11
1 files changed, 5 insertions, 6 deletions
diff --git a/testsuites/tools/generic/Makefile.am b/testsuites/tools/generic/Makefile.am
index aa6e1946da..642274f63c 100644
--- a/testsuites/tools/generic/Makefile.am
+++ b/testsuites/tools/generic/Makefile.am
@@ -9,12 +9,12 @@ noinst_SCRIPTS = difftest sorttimes
project_bspdir = $(PROJECT_ROOT)/@RTEMS_BSP@
-PREINSTALL_DIRS = $(project_bspdir)/tests
PREINSTALL_FILES = \
- $(project_bspdir)/tests/difftest \
- $(project_bspdir)/tests/sorttimes
+$(project_bspdir)/tests \
+$(project_bspdir)/tests/difftest \
+$(project_bspdir)/tests/sorttimes
-$(PREINSTALL_DIRS):
+$(project_bspdir)/tests:
@$(mkinstalldirs) $@
$(project_bspdir)/tests/difftest: difftest
@@ -23,7 +23,6 @@ $(project_bspdir)/tests/difftest: difftest
$(project_bspdir)/tests/sorttimes: sorttimes
$(INSTALL_SCRIPT) $< $@
-## HACK: install to build-tree
-all-local: $(PREINSTALL_DIRS) $(PREINSTALL_FILES)
+all-local: $(PREINSTALL_FILES)
include $(top_srcdir)/../../../../../automake/local.am